What’s Vulnerable › Vulnerabilities
CVE-2024-8277: WooCommerce Photo Reviews Premium <= 1.3.13.2 - Authentication Bypass to Account Takeover and Privilege Escalation
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-09-11 · updated 2026-06-17
- Weakness: CWE-288
Description
The WooCommerce Photo Reviews Premium plugin for WordPress is vulnerable to authentication bypass in all versions up to, and including, 1.3.13.2. This is due to the plugin not properly validating what user transient is being used in the login() function and not properly verifying the user's identity. This makes it possible for unauthenticated attackers to log in as user that has dismissed an admin notice in the past 30 days, which is often an administrator. Alternatively, a user can log in as any user with any transient that has a valid user_id as the value, though it would be more difficult to exploit this successfully.
Affected products
- villatheme WooCommerce Photo Reviews: before 1.3.14 — fixed in 1.3.14
How to fix
Upgrade to a fixed version: villatheme WooCommerce Photo Reviews 1.3.14. Check the vendor advisory for mitigations.
References
- https://codecanyon.net/item/woocommerce-photo-reviews/21245349
- https://www.wordfence.com/threat-intel/vulnerabilities/id/a1e2d370-a716-4d6b-8e23-74db2fbd0760?source=cve
Get alerted when CVE-2024-8277 or the next vulnerability affects your stack