What’s Vulnerable › Vulnerabilities
CVE-2024-8282: Ibtana – WordPress Website Builder <= 1.2.4.4 - Authenticated (Contributor+) Stored Cross-Site Scripting via align Attribute
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-10-02 · updated 2026-06-17
- Weakness: CWE-79
Description
The Ibtana – WordPress Website Builder plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the ‘align’ attribute within the 'wp:ive/ive-productscarousel' Gutenberg block in all versions up to, and including, 1.2.4.4 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with Contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
Affected products
- vowelweb Ibtana – WordPress Website Builder: before 1.2.4.5 — fixed in 1.2.4.5
How to fix
Upgrade to a fixed version: vowelweb Ibtana – WordPress Website Builder 1.2.4.5. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/browser/ibtana-visual-editor/trunk/dist/blocks.build.js
- https://plugins.trac.wordpress.org/changeset/3160421/
- https://wordpress.org/plugins/ibtana-visual-editor/#developers
- https://www.wordfence.com/threat-intel/vulnerabilities/id/0a281774-226a-4cb7-ba4a-ebb76f20eb47?source=cve
Get alerted when CVE-2024-8282 or the next vulnerability affects your stack