What’s Vulnerable › Vulnerabilities
CVE-2024-8305: MongoDB Server secondaries may crash due to forced index constraints
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-10-21 · updated 2026-06-17
- Weakness: CWE-1288
Description
prepareUnique index may cause secondaries to crash due to incorrect enforcement of index constraints on secondaries, where in extreme cases may cause multiple secondaries crashing leading to no primaries. This issue affects MongoDB Server v6.0 versions prior to 6.0.17, MongoDB Server v7.0 versions prior to 7.0.13 and MongoDB Server v7.3 versions prior to 7.3.4
Affected products
- MongoDB: from 6.0.0 before 6.0.17; from 7.0.0 before 7.0.13; from 7.3.0 before 7.3.4 — fixed in 6.0.17, 7.0.13, 7.3.4
How to fix
Upgrade to a fixed version: MongoDB 6.0.17, 7.0.13, 7.3.4. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-8305 or the next vulnerability affects your stack