What’s Vulnerable › Vulnerabilities
CVE-2024-8311: Improper Protection of Alternate Path in GitLab
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-09-12 · updated 2026-06-17
- Weakness: CWE-424
Description
An issue was discovered with pipeline execution policies in GitLab EE affecting all versions from 17.2 prior to 17.2.5, 17.3 prior to 17.3.2 which allows authenticated users to bypass variable overwrite protection via inclusion of a CI/CD template.
Affected products
- GitLab: from 17.2.0 before 17.2.5; from 17.3.0 before 17.3.2 — fixed in 17.2.5, 17.3.2
How to fix
Upgrade to a fixed version: GitLab 17.2.5, 17.3.2. Check the vendor advisory for mitigations.
References
- https://gitlab.com/gitlab-org/gitlab/-/issues/479315
- https://about.gitlab.com/releases/2024/09/11/patch-release-gitlab-17-3-2-released/
Get alerted when CVE-2024-8311 or the next vulnerability affects your stack