What’s Vulnerable › Vulnerabilities
CVE-2024-8312: Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') in GitLab
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-10-24 · updated 2026-06-17
- Weakness: CWE-79
Description
An issue has been discovered in GitLab CE/EE affecting all versions from 15.10 before 17.3.6, 17.4 before 17.4.3, and 17.5 before 17.5.1. An attacker could inject HTML into the Global Search field on a diff view leading to XSS.
Affected products
- GitLab: from 15.10.0 before 17.3.6; from 17.4.0 before 17.4.3; 17.5.0 — fixed in 17.3.6, 17.4.3
How to fix
Upgrade to a fixed version: GitLab 17.3.6, 17.4.3. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-8312 or the next vulnerability affects your stack