What’s Vulnerable › Vulnerabilities
CVE-2024-8317: WP AdCenter – Ad Manager & Adsense Ads <= 2.5.6 - Authenticated (Contributor+) Stored Cross-Site Scripting via ad_alignment Attribute
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-09-06 · updated 2026-06-17
- Weakness: CWE-79
Description
The WP AdCenter – Ad Manager & Adsense Ads plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the ‘ad_alignment’ attribute in all versions up to, and including, 2.5.6 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with Contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
Affected products
- WPeka WP AdCenter: before 2.5.7 — fixed in 2.5.7
How to fix
Upgrade to a fixed version: WPeka WP AdCenter 2.5.7. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/browser/wpadcenter/trunk/admin/class-wpadcenter-admin.php#L2922
- https://plugins.trac.wordpress.org/browser/wpadcenter/trunk/admin/class-wpadcenter-admin.php#L3020
- https://plugins.trac.wordpress.org/browser/wpadcenter/trunk/admin/class-wpadcenter-admin.php#L3127
- https://plugins.trac.wordpress.org/changeset/3146736/
- https://plugins.trac.wordpress.org/changeset/3146736/#file6
- https://wordpress.org/plugins/wpadcenter/#developers
- https://www.wordfence.com/threat-intel/vulnerabilities/id/ac7f95c7-2159-4327-ba09-da7721f1312e?source=cve
Get alerted when CVE-2024-8317 or the next vulnerability affects your stack