What’s Vulnerable › Vulnerabilities
CVE-2024-8323: Pricing Tables WordPress Plugin – Easy Pricing Tables <= 3.2.6 - Authenticated (Contributor+) Stored Cross-Site Scripting via fontFamily Attribute
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-11-06 · updated 2026-06-17
- Weakness: CWE-79
Description
The Pricing Tables WordPress Plugin – Easy Pricing Tables plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the ‘fontFamily’ attribute in all versions up to, and including, 3.2.6 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with Contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
Affected products
- Pricing Tables WordPress Plugin – Easy Pricing Tables: before 3.2.7 — fixed in 3.2.7
How to fix
Upgrade to a fixed version: Pricing Tables WordPress Plugin – Easy Pricing Tables 3.2.7. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/browser/easy-pricing-tables/trunk/includes/ept-block.php#L18
- https://plugins.trac.wordpress.org/changeset/3181961/
- https://wordpress.org/plugins/easy-pricing-tables/#developers
- https://www.wordfence.com/threat-intel/vulnerabilities/id/68fb1fd3-16aa-467f-b5f6-a6126b05e088?source=cve
Get alerted when CVE-2024-8323 or the next vulnerability affects your stack