What’s Vulnerable › Vulnerabilities
CVE-2024-8325: Gutenberg Page Builder Blocks & Ready-Made Patterns Library <= 3.2.4 - Authenticated (Contributor+) Stored Cross-Site Scripting
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-09-04 · updated 2026-06-17
- Weakness: CWE-79
Description
The Blockspare: Gutenberg Blocks & Patterns for Blogs, Magazines, Business Sites – Post Grids, Sliders, Carousels, Counters, Page Builder & Starter Site Imports, No Coding Needed plugin for WordPress is vulnerable to Stored Cross-Site Scripting via several parameters in the ‘blockspare_render_social_sharing_block’ function in all versions up to, and including, 3.2.4 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with Contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
Affected products
- BlockSpare — News, Magazine and Blog Addons for (Gutenberg) Block Editor: before 3.2.5 — fixed in 3.2.5
How to fix
Upgrade to a fixed version: BlockSpare — News, Magazine and Blog Addons for (Gutenberg) Block Editor 3.2.5. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/changeset/3145729/
- https://www.wordfence.com/threat-intel/vulnerabilities/id/c23995c6-989e-48d2-ba60-b0bf7b750245?source=cve
Get alerted when CVE-2024-8325 or the next vulnerability affects your stack