What’s Vulnerable › Vulnerabilities
CVE-2024-8350: Uncanny Groups for LearnDash <= 6.1.0.1 - Missing Authorization to Authenticated (Group Leader+) User Group Add
- Severity: low (CVSS 2.7 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-09-25 · updated 2026-06-17
- Weakness: CWE-862
Description
The Uncanny Groups for LearnDash plugin for WordPress is vulnerable to user group add due to a missing capability check on the /wp-json/ulgm_management/v1/add_user/ REST API endpoint in all versions up to, and including, 6.1.0.1. This makes it possible for authenticated attackers, with group leader-level access and above, to add users to their group which ultimately allows them to leverage CVE-2024-8349 and gain admin access to the site.
Affected products
- Uncanny Owl Uncanny Groups for LearnDash: before 6.1.1 — fixed in 6.1.1
How to fix
Upgrade to a fixed version: Uncanny Owl Uncanny Groups for LearnDash 6.1.1. Check the vendor advisory for mitigations.
References
- https://github.com/karlemilnikka/CVE-2024-8349-and-CVE-2024-8350
- https://www.wordfence.com/threat-intel/vulnerabilities/id/a38a58de-5f7d-4033-9a65-41b590b7d510?source=cve
Get alerted when CVE-2024-8350 or the next vulnerability affects your stack