What’s Vulnerable › Vulnerabilities
CVE-2024-8383
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-09-03 · updated 2026-06-17
- Weakness: CWE-1188
Description
Firefox normally asks for confirmation before asking the operating system to find an application to handle a scheme that the browser does not support. It did not ask before doing so for the Usenet-related schemes news: and snews:. Since most operating systems don't have a trusted newsreader installed by default, an unscrupulous program that the user downloaded could register itself as a handler. The website that served the application download could then launch that application at will. This vulnerability affects Firefox < 130, Firefox ESR < 128.2, and Firefox ESR < 115.15.
Affected products
- Mozilla Firefox: before 130.0 — fixed in 130.0
- Mozilla Firefox ESR: before 115.15; from 128.0 before 128.2 — fixed in 115.15, 128.2
How to fix
Upgrade to a fixed version: Mozilla Firefox 130.0; Mozilla Firefox ESR 115.15, 128.2. Check the vendor advisory for mitigations.
References
- https://bugzilla.mozilla.org/show_bug.cgi?id=1908496
- https://www.mozilla.org/security/advisories/mfsa2024-39/
- https://www.mozilla.org/security/advisories/mfsa2024-40/
- https://www.mozilla.org/security/advisories/mfsa2024-41/
- https://lists.debian.org/debian-lts-announce/2024/09/msg00012.html
- https://lists.debian.org/debian-lts-announce/2024/09/msg00025.html
Get alerted when CVE-2024-8383 or the next vulnerability affects your stack