What’s Vulnerable › Vulnerabilities
CVE-2024-8402: Improper Neutralization of Special Elements used in a Command ('Command Injection') in GitLab
- Severity: high (CVSS 7.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-03-13 · updated 2026-06-17
- Weakness: CWE-77
Description
An issue was discovered in GitLab EE affecting all versions starting from 17.2 before 17.7.7, all versions starting from 17.8 before 17.8.5, all versions starting from 17.9 before 17.9.2. An input validation issue in the Google Cloud IAM integration feature could have enabled a Maintainer to introduce malicious code.
Affected products
- GitLab: from 17.2.0 before 17.7.7; from 17.8.0 before 17.8.5; from 17.9.0 before 17.9.2 — fixed in 17.7.7, 17.8.5, 17.9.2
How to fix
Upgrade to a fixed version: GitLab 17.7.7, 17.8.5, 17.9.2. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-8402 or the next vulnerability affects your stack