What’s Vulnerable › Vulnerabilities
CVE-2024-8419: Improper Access Control vulnerability in AC4xxS devices
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-06-30 · updated 2026-06-17
- Weakness: CWE-306
Description
The endpoint hosts a script that allows an unauthorized remote attacker to put the system in a fail-safe state over the network due to missing authentication.
Affected products
- ifm electronic GmbH ifm Smart PLC AC402s: from 4.04 before 4.3.17; 6.1.8 — fixed in 4.3.17
- ifm electronic GmbH ifm Smart PLC AC422s: from 4.04 before 4.3.17; 6.1.8 — fixed in 4.3.17
- ifm electronic GmbH ifm Smart PLC AC424s: from 4.04 before 4.3.17; 6.1.8 — fixed in 4.3.17
- ifm electronic GmbH ifm Smart PLC AC432s: from 4.04 before 4.3.17; 6.1.8 — fixed in 4.3.17
- ifm electronic GmbH ifm Smart PLC AC434s: from 4.04 before 4.3.17; 6.1.8 — fixed in 4.3.17
How to fix
Upgrade to a fixed version: ifm electronic GmbH ifm Smart PLC AC402s 4.3.17; ifm electronic GmbH ifm Smart PLC AC422s 4.3.17; ifm electronic GmbH ifm Smart PLC AC424s 4.3.17; ifm electronic GmbH ifm Smart PLC AC432s 4.3.17; ifm electronic GmbH ifm Smart PLC AC434s 4.3.17. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-8419 or the next vulnerability affects your stack