What’s Vulnerable › Vulnerabilities
CVE-2024-8420: DHVC Form <= 2.4.7 - Unauthenticated Privilege Escalation
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-02-28 · updated 2026-06-17
- Weakness: CWE-266
Description
The DHVC Form plugin for WordPress is vulnerable to privilege escalation in all versions up to, and including, 2.4.7. This is due to the plugin allowing a user to supply the 'role' field when registering. This makes it possible for unauthenticated attackers to register as an administrator on sites.
Affected products
- SiteSao DHVC Form: before 2.4.8 — fixed in 2.4.8
How to fix
Upgrade to a fixed version: SiteSao DHVC Form 2.4.8. Check the vendor advisory for mitigations.
References
- https://codecanyon.net/item/dhvc-form-wordpress-form-for-visual-composer/8326593
- https://www.wordfence.com/threat-intel/vulnerabilities/id/e4d51a0c-c625-4732-b345-df02971fbffa?source=cve
Get alerted when CVE-2024-8420 or the next vulnerability affects your stack