What’s Vulnerable › Vulnerabilities
CVE-2024-8426: Pagelayer < 1.8.8 - Admin+ Stored XSS
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-05-15 · updated 2026-06-17
- Weakness: CWE-79
Description
The Page Builder: Pagelayer WordPress plugin before 1.8.8 does not sanitise and escape some of its settings, which could allow high privilege users such as admin to perform Cross-Site Scripting attacks even when unfiltered_html is disallowed
Affected products
- softaculous Page Builder: Pagelayer – Drag and Drop website builder: before 1.8.8 — fixed in 1.8.8
How to fix
Upgrade to a fixed version: softaculous Page Builder: Pagelayer – Drag and Drop website builder 1.8.8. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-8426 or the next vulnerability affects your stack