What’s Vulnerable › Vulnerabilities
CVE-2024-8427: Frontend Post Submission Manager Lite – Frontend Posting WordPress Plugin <= 1.2.2 - Missing Authorization to Authenticated (Subscriber+) Settings Update
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-09-06 · updated 2026-06-17
- Weakness: CWE-862
Description
The Frontend Post Submission Manager Lite – Frontend Posting WordPress Plugin plugin for WordPress is vulnerable to unauthorized modification of data due to a missing capability check on the save_global_settings and process_form_edit functions in all versions up to, and including, 1.2.2. This makes it possible for authenticated attackers, with Subscriber-level access and above, to update the plugin's settings and forms.
Affected products
- wpshuffle Frontend Post Submission Manager Lite – Frontend Posting WordPress Plugin: before 1.2.3 — fixed in 1.2.3
How to fix
Upgrade to a fixed version: wpshuffle Frontend Post Submission Manager Lite – Frontend Posting WordPress Plugin 1.2.3. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/browser/frontend-post-submission-manager-lite/tags/1.2.2/includes/classes/admin/class-fpsml-ajax-admin.php#L25
- https://plugins.trac.wordpress.org/changeset/3147218/frontend-post-submission-manager-lite/trunk/includes/classes/admin/class-fpsml-ajax-admin.php
- https://www.wordfence.com/threat-intel/vulnerabilities/id/e84b68b6-1ce8-45fb-823f-a61158aa4d21?source=cve
Get alerted when CVE-2024-8427 or the next vulnerability affects your stack