What’s Vulnerable › Vulnerabilities
CVE-2024-8432: Appointment & Event Booking Calendar Plugin – Webba Booking <= 5.0.48 - Missing Authorization to Authenticated (Subscriber+) CSS Settings Update
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-09-24 · updated 2026-06-17
- Weakness: CWE-862
Description
The Appointment & Event Booking Calendar Plugin – Webba Booking plugin for WordPress is vulnerable to unauthorized modification of data due to a missing capability check on the save_appearance() function in all versions up to, and including, 5.0.48. This makes it possible for authenticated attackers, with Subscriber-level access and above, to modify the booking form's CSS.
Affected products
- webba-agency Easy Appointment Booking & Scheduling System – Webba Booking Calendar: before 5.0.50 — fixed in 5.0.50
How to fix
Upgrade to a fixed version: webba-agency Easy Appointment Booking & Scheduling System – Webba Booking Calendar 5.0.50. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/browser/webba-booking-lite/tags/5.0.48/includes/class-wbk-request-manager.php#L1986
- https://plugins.trac.wordpress.org/changeset/3152926/webba-booking-lite/trunk/includes/class-wbk-request-manager.php
- https://www.wordfence.com/threat-intel/vulnerabilities/id/23b33b77-2e72-4959-bdce-646e968f2a73?source=cve
Get alerted when CVE-2024-8432 or the next vulnerability affects your stack