What’s Vulnerable › Vulnerabilities
CVE-2024-8442: Prime Slider - Addons For Elementor (Revolution of a slider, Hero Slider, Ecommerce Slider <= 3.15.18 - Authenticated (Contributor+) Stored Cross-Site Scripting via Blog Widget
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-11-07 · updated 2026-06-17
- Weakness: CWE-79
Description
The Prime Slider – Addons For Elementor (Revolution of a slider, Hero Slider, Ecommerce Slider) plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the plugin's Blog widget in all versions up to, and including, 3.15.18 due to insufficient input sanitization and output escaping on user supplied attributes. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
Affected products
- bdthemes Prime Slider – Addons for Elementor: before 3.15.19 — fixed in 3.15.19
How to fix
Upgrade to a fixed version: bdthemes Prime Slider – Addons for Elementor 3.15.19. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/browser/bdthemes-prime-slider-lite/trunk/traits/global-widget-controls.php#L2328
- https://plugins.trac.wordpress.org/changeset/3182825/
- https://wordpress.org/plugins/bdthemes-prime-slider-lite/#developers
- https://www.wordfence.com/threat-intel/vulnerabilities/id/eff765b4-22d1-4311-8a69-af6b41ef4b6e?source=cve
Get alerted when CVE-2024-8442 or the next vulnerability affects your stack