What’s Vulnerable › Vulnerabilities
CVE-2024-8478: Affiliate Super Assistent <= 1.5.3 - Unauthenticated Arbitrary Shortcode Execution
- Severity: high (CVSS 7.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-09-10 · updated 2026-06-17
- Weakness: CWE-94
Description
The The Affiliate Super Assistent plugin for WordPress is vulnerable to arbitrary shortcode execution in all versions up to, and including, 1.5.3. This is due to the software allowing users to supply arbitrary shortcodes in comments when the 'Parse comments' option is enabled. This makes it possible for unauthenticated attackers to execute arbitrary shortcodes.
Affected products
- worschtebrot Affiliate Super Assistent: before 1.5.4 — fixed in 1.5.4
How to fix
Upgrade to a fixed version: worschtebrot Affiliate Super Assistent 1.5.4. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/browser/amazonsimpleadmin/trunk/AsaCore.php#L285
- https://plugins.trac.wordpress.org/changeset?sfp_email=&sfph_mail=&reponame=&old=3147740%40amazonsimpleadmin&new=3147740%40amazonsimpleadmin&sfp_email=&sfph_mail=
- https://www.wordfence.com/threat-intel/vulnerabilities/id/7f50769c-77b8-42ff-b67d-b9b289fc51da?source=cve
Get alerted when CVE-2024-8478 or the next vulnerability affects your stack