What’s Vulnerable › Vulnerabilities
CVE-2024-8479: Simple Spoiler 1.2 - 1.3 - Unauthenticated Arbitrary Shortcode Execution
- Severity: high (CVSS 7.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-09-14 · updated 2026-06-17
- Weakness: CWE-94
Description
The The Simple Spoiler plugin for WordPress is vulnerable to arbitrary shortcode execution in versions 1.2 to 1.3. This is due to the plugin adding the filter add_filter('comment_text', 'do_shortcode'); which will run all shortcodes in comments. This makes it possible for unauthenticated attackers to execute arbitrary shortcodes.
Affected products
- Webliberty Simple Spoiler: from 1.2 before 1.4 — fixed in 1.4
How to fix
Upgrade to a fixed version: Webliberty Simple Spoiler 1.4. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/browser/simple-spoiler/trunk/simple-spoiler.php#L108
- https://plugins.trac.wordpress.org/changeset?sfp_email=&sfph_mail=&reponame=&old=3151179%40simple-spoiler&new=3151179%40simple-spoiler&sfp_email=&sfph_mail=
- https://www.wordfence.com/threat-intel/vulnerabilities/id/8ffc76d8-b841-4c26-bbc6-1f96664efe36?source=cve
Get alerted when CVE-2024-8479 or the next vulnerability affects your stack