What’s Vulnerable › Vulnerabilities
CVE-2024-8490: PropertyHive <= 2.0.19 - Cross-Site Request Forgery via save_account_details
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-09-17 · updated 2026-06-17
- Weakness: CWE-352
Description
The PropertyHive plugin for WordPress is vulnerable to Cross-Site Request Forgery in all versions up to, and including, 2.0.19. This is due to missing or incorrect nonce validation on the 'save_account_details' function. This makes it possible for unauthenticated attackers to edit the name, email address, and password of an administrator account via a forged request granted they can trick a site administrator into performing an action such as clicking on a link.
Affected products
- PropertyHive: before 2.0.20 — fixed in 2.0.20
How to fix
Upgrade to a fixed version: PropertyHive 2.0.20. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/browser/propertyhive/tags/2.0.19/includes/class-ph-ajax.php#L1089
- https://plugins.trac.wordpress.org/browser/propertyhive/tags/2.0.19/includes/class-ph-ajax.php#L976
- https://plugins.trac.wordpress.org/changeset/3152548/
- https://www.wordfence.com/threat-intel/vulnerabilities/id/17c06c83-6707-4233-a1c3-ef4cdcf93982?source=cve
Get alerted when CVE-2024-8490 or the next vulnerability affects your stack