What’s Vulnerable › Vulnerabilities
CVE-2024-8499: Checkout Field Editor (Checkout Manager) for WooCommerce <= 2.0.3 - Reflected Cross-Site Scripting via render_review_request_notice
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-10-04 · updated 2026-06-17
- Weakness: CWE-79
Description
The Checkout Field Editor (Checkout Manager) for WooCommerce plugin for WordPress is vulnerable to Reflected Cross-Site Scripting via the ‘render_review_request_notice’ function in all versions up to, and including, 2.0.3 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that execute if they can successfully trick a user into performing an action such as clicking on a link.
Affected products
- themehigh Checkout Field Editor (Checkout Manager) for WooCommerce: before 2.0.4 — fixed in 2.0.4
How to fix
Upgrade to a fixed version: themehigh Checkout Field Editor (Checkout Manager) for WooCommerce 2.0.4. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/browser/woo-checkout-field-editor-pro/trunk/admin/class-thwcfd-admin.php#L426
- https://plugins.trac.wordpress.org/changeset/3160299/
- https://www.wordfence.com/threat-intel/vulnerabilities/id/81eb8963-548f-4e94-83bd-266a19c09aab?source=cve
Get alerted when CVE-2024-8499 or the next vulnerability affects your stack