What’s Vulnerable › Vulnerabilities
CVE-2024-8505: WordPress Infinite Scroll - Ajax Load More <= 7.1.2 - Authenticated (Contributor+) Stored Cross-Site Scripting via button_label Parameter
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-10-02 · updated 2026-06-17
- Weakness: CWE-87
Description
The WordPress Infinite Scroll – Ajax Load More plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the ‘button_label’ parameter in all versions up to, and including, 7.1.2 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with Contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
Affected products
- dcooney Ajax Load More – Infinite Scroll, Load More, & Lazy Load: before 7.1.3 — fixed in 7.1.3
How to fix
Upgrade to a fixed version: dcooney Ajax Load More – Infinite Scroll, Load More, & Lazy Load 7.1.3. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/browser/ajax-load-more/trunk/core/classes/class-alm-shortcode.php
- https://plugins.trac.wordpress.org/changeset/3160896/
- https://wordpress.org/plugins/ajax-load-more/#developers
- https://www.wordfence.com/threat-intel/vulnerabilities/id/ca29158a-ca60-46c7-93a5-bcf76e7666e4?source=cve
Get alerted when CVE-2024-8505 or the next vulnerability affects your stack