What’s Vulnerable › Vulnerabilities
CVE-2024-8521: Wavelog Live QSO qso index cross site scripting
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-09-07 · updated 2026-06-17
- Weakness: CWE-79
Description
A vulnerability, which was classified as problematic, was found in Wavelog up to 1.8.0. Affected is the function index of the file /qso of the component Live QSO. The manipulation of the argument manual leads to cross site scripting. It is possible to launch the attack remotely. The exploit has been disclosed to the public and may be used. Upgrading to version 1.8.1 is able to address this issue. The patch is identified as b31002cec6b71ab5f738881806bb546430ec692e. It is recommended to upgrade the affected component.
Affected products
- wavelog: before 1.8.1 — fixed in 1.8.1
How to fix
Upgrade to a fixed version: wavelog 1.8.1. Check the vendor advisory for mitigations.
References
- https://github.com/GithubUser843205/CVEs/tree/main/CVE-2024-8521
- https://github.com/wavelog/wavelog/commit/b31002cec6b71ab5f738881806bb546430ec692e
- https://github.com/wavelog/wavelog/pull/744
- https://github.com/wavelog/wavelog/releases/tag/1.8.1
- https://vuldb.com/?ctiid.276726
- https://vuldb.com/?id.276726
- https://vuldb.com/?submit.399819
Get alerted when CVE-2024-8521 or the next vulnerability affects your stack