What’s Vulnerable › Vulnerabilities
CVE-2024-8533: Rockwell Automation OptixPanel™ Privilege Escalation Vulnerability via File Permissions
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-09-12 · updated 2026-06-17
- Weakness: CWE-269
Description
A privilege escalation vulnerability exists in the Rockwell Automation affected products. The vulnerability occurs due to improper default file permissions allowing users to exfiltrate credentials and escalate privileges.
Affected products
- Rockwellautomation 2800C Optixpanel Compact Firmware: from 4.0.0.325 before 4.0.2.116 — fixed in 4.0.2.116
- Rockwellautomation 2800S Optixpanel Standard Firmware: from 4.0.0.350 before 4.0.2.123 — fixed in 4.0.2.123
- Rockwellautomation Embedded Edge Compute Module Firmware: from 4.0.0.347 before 4.0.2.106 — fixed in 4.0.2.106
How to fix
Upgrade to a fixed version: Rockwellautomation 2800C Optixpanel Compact Firmware 4.0.2.116; Rockwellautomation 2800S Optixpanel Standard Firmware 4.0.2.123; Rockwellautomation Embedded Edge Compute Module Firmware 4.0.2.106. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-8533 or the next vulnerability affects your stack