What’s Vulnerable › Vulnerabilities
CVE-2024-8544: Pixel Cat – Conversion Pixel Manager <= 3.0.5 - Reflected Cross-Site Scripting
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-09-24 · updated 2026-06-17
- Weakness: CWE-79
Description
The Pixel Cat – Conversion Pixel Manager plugin for WordPress is vulnerable to Reflected Cross-Site Scripting due to the use of add_query_arg without appropriate escaping on the URL in all versions up to, and including, 3.0.5. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that execute if they can successfully trick a user into performing an action such as clicking on a link.
Affected products
- Pixel Cat – Conversion Pixel Manager: before 3.0.6 — fixed in 3.0.6
How to fix
Upgrade to a fixed version: Pixel Cat – Conversion Pixel Manager 3.0.6. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/browser/facebook-conversion-pixel/trunk/includes/notices/notices.php?rev=2918763#L81
- https://plugins.trac.wordpress.org/changeset?sfp_email=&sfph_mail=&reponame=&old=3151635%40facebook-conversion-pixel&new=3151635%40facebook-conversion-pixel&sfp_email=&sfph_mail=
- https://www.wordfence.com/threat-intel/vulnerabilities/id/fc4f4a78-7224-4f58-a103-7ad4df0eb36e?source=cve
Get alerted when CVE-2024-8544 or the next vulnerability affects your stack