What’s Vulnerable › Vulnerabilities
CVE-2024-8618: Page Builder: Pagelayer < 1.9.0- Admin+ Stored XSS
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-05-15 · updated 2026-06-17
- Weakness: CWE-79
Description
The Page Builder: Pagelayer WordPress plugin before 1.9.0 does not sanitise and escape some of its settings, which could allow high privilege users such as admin to perform Stored Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed (for example in multisite setup).
Affected products
- softaculous Page Builder: Pagelayer – Drag and Drop website builder: before 1.9.0 — fixed in 1.9.0
How to fix
Upgrade to a fixed version: softaculous Page Builder: Pagelayer – Drag and Drop website builder 1.9.0. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/acddcf33-0a18-499e-b42d-c8b49f2c4de5/
- https://wpscan.com/vulnerability/acddcf33-0a18-499e-b42d-c8b49f2c4de5/
Get alerted when CVE-2024-8618 or the next vulnerability affects your stack