What’s Vulnerable › Vulnerabilities
CVE-2024-8622: amCharts: Charts and Maps <= 1.4.4 - Reflected Cross-Site Scripting via Cross-Site Request Forgery
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-09-12 · updated 2026-06-17
- Weakness: CWE-79
Description
The amCharts: Charts and Maps plugin for WordPress is vulnerable to Reflected Cross-Site Scripting via the 'amcharts_javascript' parameter in all versions up to, and including, 1.4.4 due to the ability to supply arbitrary JavaScript a lack of nonce validation on the preview functionality. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that execute if they can successfully trick a user into performing an action such as clicking on a link.
Affected products
- amCharts: Charts and Maps (WordPress plugin): before 1.4.5 — fixed in 1.4.5
How to fix
Upgrade to a fixed version: amCharts: Charts and Maps (WordPress plugin) 1.4.5. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/browser/amcharts-charts-and-maps/tags/1.4.4/includes/preview.php
- https://plugins.trac.wordpress.org/changeset/3150041/
- https://www.wordfence.com/threat-intel/vulnerabilities/id/5e3593e8-3840-4db0-8269-61bbcb50d569?source=cve
Get alerted when CVE-2024-8622 or the next vulnerability affects your stack