What’s Vulnerable › Vulnerabilities
CVE-2024-8626: Logix Controllers Vulnerable to Denial-of-Service Vulnerability
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-10-08 · updated 2026-06-17
- Weakness: CWE-400
Description
Due to a memory leak, a denial-of-service vulnerability exists in the Rockwell Automation affected products. A malicious actor could exploit this vulnerability by performing multiple actions on certain web pages of the product causing the affected products to become fully unavailable and require a power cycle to recover.
Affected products
- Rockwellautomation 1756-En4Tr Firmware: 3.002
- Rockwellautomation Compact Guardlogix 5380 Firmware: from 33.011 before 33.015 — fixed in 33.015
- Rockwellautomation Compactlogix 5380 Firmware: from 33.011 before 33.015 — fixed in 33.015
- Rockwellautomation Compactlogix 5480 Firmware: from 33.011 before 33.015 — fixed in 33.015
- Rockwell Automation ControlLogix® 5580: from 33.011 before 33.015 — fixed in 33.015
- Rockwellautomation Guardlogix 5580 Firmware: from 33.011 before 33.015 — fixed in 33.015
How to fix
Upgrade to a fixed version: Rockwellautomation Compact Guardlogix 5380 Firmware 33.015; Rockwellautomation Compactlogix 5380 Firmware 33.015; Rockwellautomation Compactlogix 5480 Firmware 33.015; Rockwell Automation ControlLogix® 5580 33.015; Rockwellautomation Guardlogix 5580 Firmware 33.015. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-8626 or the next vulnerability affects your stack