What’s Vulnerable › Vulnerabilities
CVE-2024-8635: Server-Side Request Forgery (SSRF) in GitLab
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-09-12 · updated 2026-06-17
- Weakness: CWE-918
Description
A server-side request forgery issue has been discovered in GitLab EE affecting all versions starting from 16.8 prior to 17.1.7, from 17.2 prior to 17.2.5, and from 17.3 prior to 17.3.2. It was possible for an attacker to make requests to internal resources using a custom Maven Dependency Proxy URL
Affected products
- GitLab: from 16.8.0 before 17.1.7; from 17.2.0 before 17.2.5; from 17.3.0 before 17.3.2 — fixed in 17.1.7, 17.2.5, 17.3.2
How to fix
Upgrade to a fixed version: GitLab 17.1.7, 17.2.5, 17.3.2. Check the vendor advisory for mitigations.
References
- https://gitlab.com/gitlab-org/gitlab/-/issues/455273
- https://about.gitlab.com/releases/2024/09/11/patch-release-gitlab-17-3-2-released/
Get alerted when CVE-2024-8635 or the next vulnerability affects your stack