What’s Vulnerable › Vulnerabilities

CVE-2024-8640: Improper Neutralization of Special Elements used in a Command ('Command Injection') in GitLab

Description

An issue has been discovered in GitLab EE affecting all versions starting from 16.11 prior to 17.1.7, from 17.2 prior to 17.2.5, and from 17.3 prior to 17.3.2. Due to incomplete input filtering, it was possible to inject commands into a connected Cube server.

Affected products

How to fix

Upgrade to a fixed version: GitLab 17.1.7, 17.2.5, 17.3.2. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2024-8640 or the next vulnerability affects your stack