What’s Vulnerable › Vulnerabilities

CVE-2024-8648: Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') in GitLab

Description

An issue has been discovered in GitLab CE/EE affecting all versions from 16 before 17.3.7, 17.4 before 17.4.4, and 17.5 before 17.5.2. The vulnerability could allow an attacker to inject malicious JavaScript code in Analytics Dashboards through a specially crafted URL.

Affected products

How to fix

Upgrade to a fixed version: GitLab 17.3.7, 17.4.4, 17.5.2. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2024-8648 or the next vulnerability affects your stack