What’s Vulnerable › Vulnerabilities
CVE-2024-8650: Incorrect Authorization in GitLab
- Severity: medium (CVSS 5.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-12-16 · updated 2026-06-17
- Weakness: CWE-863
Description
An issue was discovered in GitLab CE/EE affecting all versions from 15.0 prior to 17.4.6, 17.5 prior to 17.5.4, and 17.6 prior to 17.6.2 that allowed non-member users to view unresolved threads marked as internal notes in public projects merge requests.
Affected products
- GitLab: from 15.0.0 before 17.4.6; from 17.5.0 before 17.5.4; from 17.6.0 before 17.6.2 — fixed in 17.4.6, 17.5.4, 17.6.2
How to fix
Upgrade to a fixed version: GitLab 17.4.6, 17.5.4, 17.6.2. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-8650 or the next vulnerability affects your stack