What’s Vulnerable › Vulnerabilities
CVE-2024-8652: Netcat CMS: reflected cross-site scripting in openstat module
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-09-19 · updated 2026-06-17
- Weakness: CWE-79
Description
A vulnerability in NetCat CMS allows an attacker to execute JavaScript code in a user's browser when they visit specific path on the site. This issue affects NetCat CMS v. 6.4.0.24126.2 and possibly others. Apply patch from vendor https://netcat.ru/ https://netcat.ru/] . Versions 6.4.0.24248 and on have the patch.
Affected products
- NetCat CMS: before 6.4.0.24248 — fixed in 6.4.0.24248
How to fix
Upgrade to a fixed version: NetCat CMS 6.4.0.24248. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-8652 or the next vulnerability affects your stack