What’s Vulnerable › Vulnerabilities
CVE-2024-8656: WPFactory Helper <= 1.7.0 - Reflected Cross-Site Scripting
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-09-13 · updated 2026-06-17
- Weakness: CWE-79
Description
The WPFactory Helper plugin for WordPress is vulnerable to Reflected Cross-Site Scripting due to the use of add_query_arg without appropriate escaping on the URL in all versions up to, and including, 1.7.0. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that execute if they can successfully trick a user into performing an action such as clicking on a link.
Affected products
- WPFactory Helper: before 1.7.1 — fixed in 1.7.1
How to fix
Upgrade to a fixed version: WPFactory Helper 1.7.1. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/browser/wpcodefactory-helper/tags/1.7.0/includes/class-alg-wpcodefactory-helper-site-key-manager.php#L350
- https://plugins.trac.wordpress.org/changeset/3150715/wpcodefactory-helper/tags/1.7.1/includes/class-alg-wpcodefactory-helper-site-key-manager.php
- https://www.wordfence.com/threat-intel/vulnerabilities/id/cb62eefe-9993-43f7-b3ae-de47c0951bee?source=cve
Get alerted when CVE-2024-8656 or the next vulnerability affects your stack