What’s Vulnerable › Vulnerabilities
CVE-2024-8671: WooEvents <= 4.1.2 - Unauthenticated Arbitrary File Overwrite
- Severity: critical (CVSS 9.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.0% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-09-24 · updated 2026-06-17
- Weakness: CWE-22
Description
The WooEvents - Calendar and Event Booking plugin for WordPress is vulnerable to arbitrary file overwrite due to insufficient file path validation in the inc/barcode.php file in all versions up to, and including, 4.1.2. This makes it possible for unauthenticated attackers to overwrite arbitrary files on the server, which can easily lead to remote code execution when the right file is deleted (such as wp-config.php).
Affected products
- Ex-Themes WooEvents - Calendar and Event Booking: before 4.1.3 — fixed in 4.1.3
How to fix
Upgrade to a fixed version: Ex-Themes WooEvents - Calendar and Event Booking 4.1.3. Check the vendor advisory for mitigations.
References
- https://codecanyon.net/item/wooevents-calendar-and-event-booking/15598178
- https://www.wordfence.com/threat-intel/vulnerabilities/id/3d7af96a-5a3c-4291-a369-f6ed78f72a3f?source=cve
Get alerted when CVE-2024-8671 or the next vulnerability affects your stack