What’s Vulnerable › Vulnerabilities
CVE-2024-8678: Revolut Gateway for WooCommerce <= 4.17.3 - Missing Authorization to Unauthenticated Order Status Update
- Severity: medium (CVSS 5.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-09-25 · updated 2026-06-17
- Weakness: CWE-862
Description
The Revolut Gateway for WooCommerce plugin for WordPress is vulnerable to unauthorized modification of data due to a missing capability check on the /wc/v3/revolut REST API endpoint in all versions up to, and including, 4.17.3. This makes it possible for unauthenticated attackers to mark orders as completed.
Affected products
- revolutbusiness Revolut Gateway for WooCommerce: before 4.17.4 — fixed in 4.17.4
How to fix
Upgrade to a fixed version: revolutbusiness Revolut Gateway for WooCommerce 4.17.4. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/changeset/3153063/
- https://www.wordfence.com/threat-intel/vulnerabilities/id/74dad6f0-0760-4420-b8cc-dc84cafd9b0d?source=cve
Get alerted when CVE-2024-8678 or the next vulnerability affects your stack