What’s Vulnerable › Vulnerabilities
CVE-2024-8689: ActiveMQ Content Pack: Cleartext Exposure of Credentials
- Severity: medium (CVSS 6.0 v4.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-09-11 · updated 2026-06-17
- Weakness: CWE-312
Description
A problem with the ActiveMQ integration for both Cortex XSOAR and Cortex XSIAM can result in the cleartext exposure of the configured ActiveMQ credentials in log bundles.
Affected products
- Palo Alto Networks ActiveMQ Content Pack: from 1.1.0 before 1.1.15 — fixed in 1.1.15
How to fix
Upgrade to a fixed version: Palo Alto Networks ActiveMQ Content Pack 1.1.15. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-8689 or the next vulnerability affects your stack