What’s Vulnerable › Vulnerabilities
CVE-2024-8704: Advanced File Manager <= 5.2.8 - Authenticated (Administrator+) Local JavaScript File Inclusion via fma_locale
- Severity: high (CVSS 7.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-09-26 · updated 2026-06-17
- Weakness: CWE-22
Description
The Advanced File Manager plugin for WordPress is vulnerable to Local JavaScript File Inclusion in all versions up to, and including, 5.2.8 via the 'fma_locale' parameter. This makes it possible for authenticated attackers, with Administrator-level access and above, to include and execute arbitrary files on the server, allowing the execution of any PHP code in those files. This can be used to bypass access controls, obtain sensitive data, or achieve code execution in cases where images and other “safe” file types can be uploaded and included.
Affected products
- saadiqbal Advanced File Manager – Ultimate File Manager for WordPress And Document Library Solution: before 5.2.9 — fixed in 5.2.9
How to fix
Upgrade to a fixed version: saadiqbal Advanced File Manager – Ultimate File Manager for WordPress And Document Library Solution 5.2.9. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/browser/file-manager-advanced/trunk/application/class_fma_main.php#L152
- https://plugins.trac.wordpress.org/changeset/3157713/
- https://www.wordfence.com/threat-intel/vulnerabilities/id/5b783cc6-d79d-43ef-948a-a1953d383ca3?source=cve
Get alerted when CVE-2024-8704 or the next vulnerability affects your stack