What’s Vulnerable › Vulnerabilities
CVE-2024-8725: Advanced File Manager <= 5.2.8 - Authenticated (Subscriber+) Limited File Upload
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-09-26 · updated 2026-06-17
- Weakness: CWE-434
Description
Multiple plugins and/or themes for WordPress are vulnerable to Limited File Upload in various versions. This is due to a lack of proper checks to ensure lower-privileged roles cannot upload .css and .js files to arbitrary directories. This makes it possible for authenticated attackers, with Subscriber-level access and above, and granted permissions by an administrator, to upload .css and .js files to any directory within the WordPress root directory, which could lead to Stored Cross-Site Scripting. The Advanced File Manager Shortcodes plugin must be installed to exploit this vulnerability.
Affected products
- saadiqbal Advanced File Manager – Ultimate File Manager for WordPress And Document Library Solution: before 5.2.9 — fixed in 5.2.9
How to fix
Upgrade to a fixed version: saadiqbal Advanced File Manager – Ultimate File Manager for WordPress And Document Library Solution 5.2.9. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/browser/file-manager-advanced/trunk/application/class_fma_main.php#L24
- https://plugins.trac.wordpress.org/browser/file-manager-advanced/trunk/application/class_fma_shortcode.php#L28
- https://plugins.trac.wordpress.org/changeset/3157713/
- https://www.wordfence.com/threat-intel/vulnerabilities/id/ce2b4f93-93a6-480f-a877-ca47bd133bb6?source=cve
Get alerted when CVE-2024-8725 or the next vulnerability affects your stack