What’s Vulnerable › Vulnerabilities
CVE-2024-8737: PDF Thumbnail Generator <= 1.3 - Reflected Cross-Site Scripting
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-09-13 · updated 2026-06-17
- Weakness: CWE-79
Description
The PDF Thumbnail Generator plugin for WordPress is vulnerable to Reflected Cross-Site Scripting due to the use of add_query_arg without appropriate escaping on the URL in all versions up to, and including, 1.3. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that execute if they can successfully trick a user into performing an action such as clicking on a link.
Affected products
- kubiq PDF Thumbnail Generator: before 1.4 — fixed in 1.4
How to fix
Upgrade to a fixed version: kubiq PDF Thumbnail Generator 1.4. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/browser/pdf-thumbnail-generator/tags/1.3/pdf-thumbnail-generator.php#L184
- https://plugins.trac.wordpress.org/changeset/3151055/
- https://www.wordfence.com/threat-intel/vulnerabilities/id/b183587b-95bd-4e82-bfc7-db5a8fbd58f9?source=cve
Get alerted when CVE-2024-8737 or the next vulnerability affects your stack