What’s Vulnerable › Vulnerabilities
CVE-2024-8764: Improper Authorization in lunary-ai/lunary
- Severity: high (CVSS 7.5 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-03-20 · updated 2026-06-17
- Weakness: CWE-1333
Description
A vulnerability in lunary-ai/lunary, as of commit be54057, allows users to upload and execute arbitrary regular expressions on the server side. This can lead to a Denial of Service (DoS) condition, as certain regular expressions can cause excessive resource consumption, blocking the server from processing other requests.
Affected products
- lunary-ai/lunary: before 1.4.23 — fixed in 1.4.23
How to fix
Upgrade to a fixed version: lunary-ai/lunary 1.4.23. Check the vendor advisory for mitigations.
References
- https://github.com/lunary-ai/lunary/commit/7ff89b0304d191534b924cf063f3648206d497fa
- https://huntr.com/bounties/088c04a1-d23a-47f2-9d7c-b84d7332868d
Get alerted when CVE-2024-8764 or the next vulnerability affects your stack