What’s Vulnerable › Vulnerabilities
CVE-2024-8765: Improper Path Equivalence Resolution in lunary-ai/lunary
- Severity: high (CVSS 7.3 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-03-20 · updated 2026-06-17
- Weakness: CWE-41
Description
In lunary-ai/lunary, the privilege check mechanism is flawed in version git afc5df4. The system incorrectly identifies certain endpoints as public if the path contains '/auth/' anywhere within it. This allows unauthenticated attackers to access sensitive endpoints by including '/auth/' in the path. As a result, attackers can obtain and modify sensitive data and utilize other organizations' resources without proper authentication.
Affected products
- lunary-ai/lunary: before 1.4.23 — fixed in 1.4.23
How to fix
Upgrade to a fixed version: lunary-ai/lunary 1.4.23. Check the vendor advisory for mitigations.
References
- https://github.com/lunary-ai/lunary/commit/7ff89b0304d191534b924cf063f3648206d497fa
- https://huntr.com/bounties/4908cfcf-607a-412a-9635-966cbb08bb49
Get alerted when CVE-2024-8765 or the next vulnerability affects your stack