What’s Vulnerable › Vulnerabilities
CVE-2024-8794: BA Book Everything <= 1.6.20 - Unauthenticated Arbitrary User Password Reset
- Severity: medium (CVSS 5.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-09-24 · updated 2026-06-17
- Weakness: CWE-620
Description
The BA Book Everything plugin for WordPress is vulnerable to arbitrary password reset in all versions up to, and including, 1.6.20. This is due to the reset_user_password() function not verifying a user's identity prior to setting a password. This makes it possible for unauthenticated attackers to reset any user's passwords, including administrators. It's important to note that the attacker will not have access to the generated password, therefore, privilege escalation is not possible.
Affected products
- bookingalgorithms BA Book Everything: before 1.6.21 — fixed in 1.6.21
How to fix
Upgrade to a fixed version: bookingalgorithms BA Book Everything 1.6.21. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/browser/ba-book-everything/tags/1.6.20/includes/class-babe-my-account.php#L610
- https://plugins.trac.wordpress.org/browser/ba-book-everything/tags/1.6.20/includes/class-babe-users.php#L266
- https://plugins.trac.wordpress.org/changeset/3152728/ba-book-everything/trunk/includes/class-babe-users.php
- https://www.wordfence.com/threat-intel/vulnerabilities/id/4e261b0e-5ca3-4f5c-acc0-41abee31b148?source=cve
Get alerted when CVE-2024-8794 or the next vulnerability affects your stack