What’s Vulnerable › Vulnerabilities
CVE-2024-8795: BA Book Everything <= 1.6.20 - Cross-Site Request Forgery to Email Address Update/Account Takeover
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-09-24 · updated 2026-06-17
- Weakness: CWE-352
Description
The BA Book Everything plugin for WordPress is vulnerable to Cross-Site Request Forgery in all versions up to, and including, 1.6.20. This is due to missing or incorrect nonce validation on the my_account_update() function. This makes it possible for unauthenticated attackers to update a user's account details via a forged request granted they can trick a site administrator into performing an action such as clicking on a link. This can be leveraged to reset a user's password and gain access to their account.
Affected products
- bookingalgorithms BA Book Everything: before 1.6.21 — fixed in 1.6.21
How to fix
Upgrade to a fixed version: bookingalgorithms BA Book Everything 1.6.21. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/browser/ba-book-everything/tags/1.6.20/includes/class-babe-my-account.php#L562
- https://plugins.trac.wordpress.org/browser/ba-book-everything/tags/1.6.20/includes/class-babe-users.php#L203
- https://plugins.trac.wordpress.org/changeset?sfp_email=&sfph_mail=&reponame=&old=3152728%40ba-book-everything&new=3152728%40ba-book-everything&sfp_email=&sfph_mail=#file3
- https://www.wordfence.com/threat-intel/vulnerabilities/id/b691560e-e285-467c-9d52-1620c63de1f0?source=cve
Get alerted when CVE-2024-8795 or the next vulnerability affects your stack