What’s Vulnerable › Vulnerabilities
CVE-2024-8809: Cohesive Networks VNS3 Command Injection Remote Code Execution Vulnerability
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-11-22 · updated 2026-06-17
- Weakness: CWE-78
Description
Cohesive Networks VNS3 Command Injection Remote Code Execution Vulnerability. This vulnerability allows remote attackers to execute arbitrary code on affected installations of Cohesive Networks VNS3. Authentication is required to exploit this vulnerability. The specific flaw exists within the web service, which listens on TCP port 8000 by default. The issue results from the lack of proper validation of a user-supplied string before using it to execute a system call. An attacker can leverage this vulnerability to execute code in the context of root. Was ZDI-CAN-24178.
Affected products
- Cohesive Networks VNS3: from 4.6.1 before 6.2.8; from 6.6.0 before 6.6.7 — fixed in 6.2.8, 6.6.7
How to fix
Upgrade to a fixed version: Cohesive Networks VNS3 6.2.8, 6.6.7. Check the vendor advisory for mitigations.
References
- https://cohesive.net/support/security-responses/
- https://www.zerodayinitiative.com/advisories/ZDI-24-1233/
Get alerted when CVE-2024-8809 or the next vulnerability affects your stack