What’s Vulnerable › Vulnerabilities
CVE-2024-8842: PDF-XChange Editor RTF File Parsing Uninitialized Variable Remote Code Execution Vulnerability
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-11-22 · updated 2026-06-17
- Weakness: CWE-457
Description
PDF-XChange Editor RTF File Parsing Uninitialized Variable Remote Code Execution Vulnerability. This vulnerability allows remote attackers to execute arbitrary code on affected installations of PDF-XChange Editor. User interaction is required to exploit this vulnerability in that the target must visit a malicious page or open a malicious file. The specific flaw exists within the parsing of RTF files. The issue results from the lack of proper initialization of memory prior to accessing it. An attacker can leverage this vulnerability to execute code in the context of the current process. Was ZDI-CAN-24481.
Affected products
- PDF-XChange Pdf-Tools: from 10.3.0.386 before 10.4.0.388 — fixed in 10.4.0.388
- PDF-XChange Editor: from 10.3.0.386 before 10.4.0.388 — fixed in 10.4.0.388
How to fix
Upgrade to a fixed version: PDF-XChange Pdf-Tools 10.4.0.388; PDF-XChange Editor 10.4.0.388. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-8842 or the next vulnerability affects your stack