What’s Vulnerable › Vulnerabilities
CVE-2024-8851: Polls CP <= 1.0.75 - Admin+ Stored Cross-Site Scripting
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-05-15 · updated 2026-06-17
- Weakness: CWE-79
Description
The Polls CP WordPress plugin before 1.0.77 does not sanitise and escape some of its poll settings, which could allow high privilege users such as admin to perform Stored Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed (for example in multi site setup).
Affected products
- Polls CP: before 1.0.77 — fixed in 1.0.77
How to fix
Upgrade to a fixed version: Polls CP 1.0.77. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-8851 or the next vulnerability affects your stack