What’s Vulnerable › Vulnerabilities
CVE-2024-8852: All-in-One WP Migration and Backup <= 7.86 - Unauthenticated Information Disclosure via Error Logs
- Severity: medium (CVSS 5.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.2% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-10-22 · updated 2026-06-17
- Weakness: CWE-200
Description
The All-in-One WP Migration and Backup plugin for WordPress is vulnerable to Sensitive Information Exposure in all versions up to, and including, 7.86 through publicly exposed log files. This makes it possible for unauthenticated attackers to view potentially sensitive information such as full paths contained in the exposed log files.
Affected products
- servmask All-in-One WP Migration and Backup: before 7.87 — fixed in 7.87
How to fix
Upgrade to a fixed version: servmask All-in-One WP Migration and Backup 7.87. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/browser/all-in-one-wp-migration/tags/7.86/functions.php#L297
- https://plugins.trac.wordpress.org/changeset?sfp_email=&sfph_mail=&reponame=&old=3168605%40all-in-one-wp-migration&new=3168605%40all-in-one-wp-migration&sfp_email=&sfph_mail=
- https://www.wordfence.com/threat-intel/vulnerabilities/id/c4901d9d-7b37-40d5-a42b-59c80bbbe8ff?source=cve
Get alerted when CVE-2024-8852 or the next vulnerability affects your stack