What’s Vulnerable › Vulnerabilities
CVE-2024-8853: Webo-facto <= 1.40 - Unauthenticated Privilege Escalation
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-09-20 · updated 2026-06-17
- Weakness: CWE-269
Description
The Webo-facto plugin for WordPress is vulnerable to privilege escalation in versions up to, and including, 1.40 due to insufficient restriction on the 'doSsoAuthentification' function. This makes it possible for unauthenticated attackers to make themselves administrators by registering with a username that contains '-wfuser'.
Affected products
- jeremieglotin Webo-facto: before 1.41 — fixed in 1.41
How to fix
Upgrade to a fixed version: jeremieglotin Webo-facto 1.41. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/browser/webo-facto-connector/tags/1.40/WeboFacto/Sso.php#L78
- https://plugins.trac.wordpress.org/changeset/3153062/webo-facto-connector
- https://www.wordfence.com/threat-intel/vulnerabilities/id/c1280ceb-9ce8-47fc-8fd3-6af80015dea9?source=cve
Get alerted when CVE-2024-8853 or the next vulnerability affects your stack