What’s Vulnerable › Vulnerabilities
CVE-2024-8858: Elementor Addons by Livemesh <= 8.5 - Authenticated (Contributor+) Stored Cross-Site Scripting via piechart_settings Parameter
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-09-25 · updated 2026-06-17
- Weakness: CWE-79
Description
The Elementor Addons by Livemesh plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the ‘piechart_settings’ parameter in all versions up to, and including, 8.5 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with Contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. CVE-2024-47303 is likely a duplicate of this issue.
Affected products
- Livemesh Addons by Elementor: before 8.5.1 — fixed in 8.5.1
How to fix
Upgrade to a fixed version: Livemesh Addons by Elementor 8.5.1. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/browser/addons-for-elementor/trunk/templates/addons/piecharts/loop.php#L21
- https://plugins.trac.wordpress.org/changeset/3153346/
- https://wordpress.org/plugins/addons-for-elementor/#developers
- https://www.wordfence.com/threat-intel/vulnerabilities/id/d3c2e5fe-cc02-479e-9f33-e1a783088596?source=cve
Get alerted when CVE-2024-8858 or the next vulnerability affects your stack